Error: NETWORK_NAME is not defined when init_indy_keys for starting node on local machine


Hi all,

when I follow this document “” to start the indy node on my local machine. when I execute “init_indy_node Alpha 9701 9702 [–seed 111111111111111111111111111Alpha]”, It throw an error like below:

Is anyone know how to set the network name? Many thanks for your help!


Hi Peter, did you figure out how to fix the issue? I get the same error (on Ubuntu). I followed the steps in and could run ‘sudo apt-get install indy-node’. I set the NETWORK_NAME to be sandbox in /etc/indy/ (not sure what is the correct network name).

sudo init_indy_node Alpha 9701 9702 [--seed 111111111111111111111111111Alpha]
Traceback (most recent call last):
  File "/usr/local/bin/init_indy_keys", line 6, in <module>
    from plenum.common.keygen_utils import initNodeKeysForBothStacks
  File "/usr/local/lib/python3.5/dist-packages/plenum/", line 73, in <module>
  File "/usr/local/lib/python3.5/dist-packages/plenum/", line 45, in setup_plugins
    config = getConfigOnce()
  File "/usr/local/lib/python3.5/dist-packages/plenum/common/", line 106, in getConfigOnce
    return _getConfig(general_config_dir)
  File "/usr/local/lib/python3.5/dist-packages/plenum/common/", line 87, in _getConfig
  File "/usr/local/lib/python3.5/dist-packages/plenum/common/", line 32, in extend_with_external_config
    config = getInstalledConfig(*extender)
  File "/usr/local/lib/python3.5/dist-packages/plenum/common/", line 26, in getInstalledConfig
  File "/etc/indy/", line 3, in <module>
    NETWORK_NAME = sandbox
NameError: name 'sandbox' is not defined


Solved. The NETWORK_NAME (e.g. sandbox) must be in quotes (e.g. ‘sandbox’) in /etc/indy/