"ImportError" while launching sovrin


#1

Hello,

First, I should say I’m new to sovrin so apologies in advance if the answer to my problem is obvious.

After a first attempt to experiment with soverin but that I had to terminate due to some firewall issues, I created a clean Ubuntu 16 VM on Windows Azure then followed one by one the steps on:

  1. https://github.com/evernym/plenum#installing-python-35-and-libsodium
    (section Installing python 3.5 and libsodium)
  2. https://docs.google.com/document/d/1CyggP4nNPyx4SELNZEc2FOeln6G0F22B37cAVtB_FBM/edit

All went fine, including pip install sovrin. But when running sovrin, I receive the following error message:

Loading module /home/sovrin/.virtualenvs/sovtest/lib/python3.5/site-packages/config/config-crypto-example1.py
Module loaded.
Traceback (most recent call last):
File "/home/sovrin/.virtualenvs/sovtest/bin/sovrin", line 30, in <module>
from sovrin.common.util import getConfig
File "/home/sovrin/.virtualenvs/sovtest/lib/python3.5/site-packages/sovrin/__init__.py", line 8, in <module>
from sovrin.common.plugin_helper import writeAnonCredPlugin
File "/home/sovrin/.virtualenvs/sovtest/lib/python3.5/site-packages/sovrin/common/plugin_helper.py", line 3, in <module>
from sovrin.common.util import getConfig
File "/home/sovrin/.virtualenvs/sovtest/lib/python3.5/site-packages/sovrin/common/util.py", line 20, in <module>
from plenum.common.util import isHex, error, getConfig asPlenumConfig, `
ImportError: cannot import name 'getConfig'

I thought there was something wrong with the plenum installation so I ran it again (pip install plenum) and also tested it. But the error keeps coming.

Does anyone have an idea what could be wrong please?


#2

Hi Fabien - I’ll ask one of the tech team to get back to you on this.

Andy


#3

@fabienpe Looks like you are using an older version of sovrin, can you upgrade and try again? This is how you upgrade pip install -U --no-cache-dir sovrin


#4

Thanks @lovesh. This worked out. But I’m still not at the end of the tunnel. When I go through the Getting Started manual, I get the following error:
Remote endpoint not found, can not connect to Faber College
after running the following commands:
load sample/faber-invitation.sovrin
connect test
accept invitation from "Faber College"


#5

We have had some issues with housekeeping of validators and with our communication protocol, also we are facing a technical issue with our cloud hosting provider, All this results in some of the machines being unavailable as of now