IndyError: PoolLedgerTimeout when connecting to Sovrin Sandbox Network


#1

I successfully ran Alice sample and my own use case on my local ledger (MacOS, Docker) but when I tried to connect to Sovrin Sandbox Network (indy.openPoolLedger) using this pool transactions sandbox file (https://github.com/sovrin-foundation/sovrin/blob/stable/sovrin/pool_transactions_sandbox_genesis) I get IndyError: PoolLedgerTimeout.

Facts:

  1. I am using NodeJS wrapper on top of Indy SDK
  2. I already registered my TRUST ANCHOR on https://s3.us-east-2.amazonaws.com/evernym-cs/sovrin-STNnetwork/www/trust-anchor.html

Is there anything I need to do extra to connect to Sovrin Sandbox Network? I can successfully telnet to the nodes in the genesis file via client port from my machine (for example, telnet 52.64.96.160 9702). How could I troubleshoot this? Any advice?

Thank you!


#2

The genesis file only works if you are going with a strictly default configuration. You are using nodejs on a mac, so it might not be playing very nicely. Try verifying the ip addresses and ports listed in the genesis file, and make sure they match up with your configuration. I think by default, they point to 127.0.0.1, which would probably be causing your problems right now.

For future reference, you’ll often get better help faster on the Hyperledger RocketChat instance. The Indy-SDK channel is a good place to ask these questions.


#3

The version of indy-node currently deployed on the STN is incompatible with the transaction format of the current <head> of the stable repo, due to a bug that was discovered in that software version before it was rolled out to the STN. You will want to use this version of the genesis file: https://raw.githubusercontent.com/sovrin-foundation/sovrin/1.1.55-master/sovrin/pool_transactions_sandbox_genesis

When you connect to the pool, in newer versions of libindy you will also need to specify protocol-version=1


#4

P.S. Hopefully we will be able to bring the repo and what is on the STN back into synchronization by the end of next week.


#5

Thank you Mike (@mgbailey). Changing the genesis file to https://raw.githubusercontent.com/sovrin-foundation/sovrin/1.1.55-master/sovrin/pool_transactions_sandbox_genesis and setting the protocol-version to 1 did it for me. I successfully connected to STN.


#6

@andrewtabit Sorry I believe I misunderstood your question! Thank you @mgbailey for your help.