Installation error when installing indy-node

I’m trying to install indy-node on a fresh Ubuntu 18.04 machine in order to create a small network with 4 nodes.

when following the installation instructions I get the following error:

localhost:~$ sudo apt-get install indy-node

The following packages have unmet dependencies:
 indy-node : Depends: indy-plenum (= 1.12.2) but it is not going to be installed
             Depends: libsodium18 but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ve tried installing libsodium18 but I get the following error:

Package libsodium18 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libsodium18' has no installation candidate

Likewise, trying to install indy-plenum has a bunch of ‘unmet dependency’ errors.

I have also tried to install indy-node via python + pip, but that doesn’t seem to work either.

Has anyone successfully installed indy-node, and if so, can you share the secret?

In the end the solution that worked for me was to downgrade to Ubuntu 16.04 - that seemed to fixed the dependencies issue and allow the installation to proceed

Hi,
i also have some issue, please help me too

Still waiting for someone to help me with the issue?

TIA ..