JNA required 6.0.0

Hi everybody!

i’m trying to build an android app with indy sdk (1.13.0). I set up JNA 5.2.0 and i follow the guide on github repo. I develop the app based on huawei AMN-LX9 with android 9 and everything works. I tried the app on a samsung a3 2015 and it works.
Then i decide to try it on Huawei p20 lite with android 9 and it return this error:

here is an incompatible JNA native library installed on this system
Expected: 6.0.0
Found: 5.2.0
/system/lib64:/product/lib64.
To resolve this issue you may do one of the following:
- remove or uninstall the offending library
- set the system property jna.nosys=true
- set jna.boot.library.path to include the path to the version of the
jnidispatch library included with the JNA jar file you are using

Same error on Galaxy note 8.

I tried to search if there’s a new version of JNA but the latest is 5.5.0, so the problem still remains. Anyone has encounter this error?

Thanks