Sovrin getting started guide


#1

You’ll find the Getting Started guide here:

https://github.com/sovrin-foundation/sovrin/blob/master/getting-started.md


How to Start Integrating Sovrin
#2

I hope this is the right place for this comment.

I’ve been trying to install sovrin on my Mac (MacOS Sierra 10.12)

I get this error:

In file included from charm/core/math/pairing/pairingmodule.c:30:
charm/core/math/pairing/pairingmodule.h:37:10: fatal error: 'gmp.h' file not found
#include <gmp.h>
         ^
1 error generated.
error: command '/usr/bin/clang' failed with exit status 1

----------------------------------------

Command “/Library/Frameworks/Python.framework/Versions/3.5/bin/python3.5 -u -c “import setuptools, tokenize;file=’/private/tmp/pip-build-gibx67fc/Charm-Crypto/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-ll3v2xol-record/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /private/tmp/pip-build-gibx67fc/Charm-Crypto/

I’ve tried installing and uninstalling gmp in various ways but no luck yet


#3

Thanks Howard - This is one for @danielh


#4

This discussion is unfolding on github because it’s about a bug. Please refer there instead: https://github.com/evernym/anoncreds/issues/4


#5

Ironically I did refer Howard here to this forum to post this question, as well as putting on GitHub which he did originally.


#6

On my Mac, I ended up using brew to install gmp, pbc and libsodium.

Then finally to get charm-crypto built I dd something like:

wget https://github.com/JHUISI/charm/archive/dev.zip
unzip dev.zip
pushd charm-dev
./configure.sh --python=$(which python3.5) --enable-darwin
make
sudo make install

Then --enable-darwin was the important bit.

Hope that helps
Andy


#7

In order to get Charm to install I also had to install XCode Command Line tools.

Here is a description of the issue


#8

Hi @Kittovski - are you now up & running OK?


#9

Yes - all good now!:slight_smile:


#10

Folks - I have tried the Xcode approach with the latest version of Mac OS including repairing the crypto.h file for openssl and was unable to fix the issue reported above. My mac os ver is 10.12.6.

I then decided to do a simple docker container for Ubuntu with a docker attach so that I can hit my local sovrin cluster of 4 validator nodes. Unfortunately, I get a similar error:

x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DBENCHMARK_ENABLED=1 -Icharm/core/utilities/ -Icharm/core/benchmark/ -I/usr/include/python3.5m -c charm/core/math/pairing/pairingmodule.c -o build/temp.linux-x86_64-3.5/charm/core/math/pairing/pairingmodule.o
In file included from charm/core/math/pairing/pairingmodule.c:30:0:
charm/core/math/pairing/pairingmodule.h:37:17: fatal error: gmp.h: No such file or directory
compilation terminated.
error: command ‘x86_64-linux-gnu-gcc’ failed with exit status 1

----------------------------------------

Command “/usr/bin/python3 -u -c “import setuptools, tokenize;file=’/tmp/pip-build-t8l864o5/Charm-Crypto/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-5oj3fh_2-record/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /tmp/pip-build-t8l864o5/Charm-Crypto/
root@619ca0be244e:/#

In both cases the issue is with the gmp.h file.

Is there a better crypto package that works and is more dev-ops friendly across platforms?

Any suggestions?


#11

The new location for the Getting Started Guide is here.


#12

Hi,
I am using windows 64 bit and am stuck up at the getting started. In the getting started guide the link to install sovrin by automated VM machine is also broken. As per the getting-started pdf, pip install -U --no-cache-dir sovrin-client ends up with “Don’t know how to compile leveldb for windows!” and sovrin is not recognized as an internal or external command.

Can anyone help me here in any.both the approaches? A bit frustrating breaking head at the very start.


#13

There is a project underway to rename all elements that were “sovrin” to “indy”. As a result, the master and the stable branches are pretty incompatible at the moment. So to run through things, please stick to the stable branches of all repos. What this means, is instead of accessing the VM spin-up instructions at https://github.com/evernym/sovrin-environments/blob/master/vagrant/training/vb-multi-vm/TestSovrinClusterSetup.md, go to https://github.com/evernym/sovrin-environments/blob/stable/vagrant/training/vb-multi-vm/TestSovrinClusterSetup.md

Also, please note that the sovrin nodes as well as the demo agents and CLI will run only in Ubuntu at this time. The VMs that are spun up in the “TestSovrinClusterSetup.md” storyboard are the right type to do this.


#14

A new Indy version has been rolled out to stable, and the Getting Started Guide and the associated Test Network Setup have been updated accordingly. The link in the Getting Started Guide to the Test Network setup is now correct. As stated by @TechWritingWhiz, the correct link to the Getting Started Guide is https://github.com/hyperledger/indy-node/blob/stable/getting-started.md