Testing environment for Sovrin


#1

Hello team,

I was wondering which is the most recommended setup for starting to experiment with the Sovrin Ledger myself? Is there a “sandbox” ledger I can connect to (with a home-made client) without having to run a node? …Or should I necessarily run a validator node? If this is so, is there a way to run a “private” Sovrin network so I don’t pollute the real ledger?.. I have still quite a few questions on this matter.

I want to start developing a test agent and client so I can record and query for test claims on the Sovrin Ledger. Which is the best route to take?

Thanks.


#2

I’ve created a getting started guide to running a standalone Sovrin network (in the docs folder of the git repo).

Currently it stands up 4 validation (steward) nodes, and the connects the Agents detailed in the getting started guide - allowing you to follow through that guide.

I am hoping to get a custom agent bootstrapped and setup and will add that to the guide once I’ve figured that bit out.


#3

Thanks Andy!

That was really helpful.


#4

Hey, I was wondering if it’s normal to see so many “connection refused” messages on the nodes’ log.

Does that look good to you?


#5

Nope - I had this when setting things up and I can think of two reasons why you may be getting this.

  1. You need at least 4 sovrin nodes running (it seems like that is the minimum to provide the initial consensus and voting for master and backup)

  2. You haven’t onboarded the Faber/Acme… agent correctly (e.g. Using the Sovrin client, set the attributes for the did and endpoint for those clients).

I’ve had a number of times when I thought I had everything setup properly (4 nodes, onboarded the agents, etc) BUT for some reason it just wouldn’t set it. Restarting the nodes and re-on boarding seems it’susually fix it!


#6

Hey Andy,

Well I had 4 nodes running (only 3 terminal windows showing on the screenthough)… And why should it matter if agents are not onboarded? Shouldn’t validator nodes just be functionally complete without the agents?

Also, after I ran the test agent (faber) all 4 nodes went down. Pretty weird!

Alright, I’ll keep on restarting and trying.

Thanks alot.


#7

Hello, still not being able to successfully run this test… Can anyone help me?


#8

I see many connection refused messages on my nodes but this did not prevent things to run fine (at least I could run the Faber scenario on the sovrin client). At some point I had the nodes crashing when running the test but after resetting the sovrin environment as indicated on https://github.com/sovrin-foundation/sovrin/blob/master/docs/Sovrin_Running_Locally.md all went fine. Have you tried resetting the environment?


#9

@fabienpe, what exactly do you mean by resetting the environment?

I’ve tried to run the test many times, and all nodes crash when the faber agent connects to network.


#10

On the page I’ve indicated, there is a section called “Resetting the Sovrin environment.” When I applied that, I did not encounter the problem anymore.


#11

Can you please paste the error that appears when the nodes crash?