Verifying proof after credential revocation results in true


I noticed the following problem. Despite the revocation of a credential a proof gets verified to true. I made a simple timeline which describes the events.

What semantics do the intervals and timestamps in the proof request and in the revocation states have?

I’m using ISSUANCE_ON_DEMAND for the revocation and I’m writing the delta to the ledger each time a credential has beed issued to a prover.

Can you please share your code demonstrating the error? In the crypto code, there is a test for the behavior you described. Here it is.

Thanks @lovesh.
Here is the full code demonstrating the error. But maybe I’m making something wrong with the parameters, especially the intervals. Please have a look.
I extendet the previously snippet from the other topic.

Your code looks fine. Left comments at

Hey, I answered the comments here

Your last question was abbout if there is a list of issued and revoked credential indices in the Ledger.buildGetRevocRegRequest response. There were none lists. Even if i make the same request with a current timestamp there are no lists.

I updated the code with the new outputs.

I replied in the github commit.

I commented in the github commit. The delta respsonse for the verifier contained only empty lists for issued and revoked credentials. I also tried to use a timestamp which is after the timestamp of the proof, but i get the same result. Updated the code on github.

If I compare the txn time of the delta immediatly after revoking the credential and writing it to the ledger, i notice that the credential revoc id is contained in the list:

timestamp - 1564227753 --> “revoked”: [1]

when i read the delta for the interval 1564227753 - 1564227753 the response contains only empty lists.

Then this might be an issue because of 0 delta. Can you try with a non-zero delta like 1564227753 - 1564227752?

Hey lovesh,
sorry for the late reply. Its the same. The lists are empty even if the delta is > 0. Seems to be a bug.

Hi @jsh4rk. Can you please report it on Jira?

Done :slight_smile:

1 Like